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ASP.NET Core Documentation


주의

ASP.NET 5 has been renamed to ASP.NET Core 1.0. Read more [https://blogs.msdn.microsoft.com/webdev/2016/02/01/an-update-on-asp-net-core-and-net-core/].




주석

This documentation is a work in progress. Topics marked with a 🔧 are placeholders that have not been written yet. You can track the status of these topics through our public documentation issue tracker [https://github.com/aspnet/docs/issues]. Learn how you can contribute [https://github.com/aspnet/Docs/blob/master/CONTRIBUTING.md] on GitHub.
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Getting Started 시작하기


	.NET Core [https://microsoft.com/net/core] 설치해주십시오.

	신규 .NET Core 프로젝트를 생성해주십시오.




mkdir aspnetcoreapp
cd aspnetcoreapp
dotnet new









	project.json 파일에서 Kestrel HTTP 서버 패키지를 종속성 (dependencies) 항목에 추가하여 저장해주십시오.




{
  "version": "1.0.0-*",
  "buildOptions": {
    "emitEntryPoint": true
  },
  "dependencies": {
    "Microsoft.NETCore.App": {
      "type": "platform",
      "version": "1.0.0-rc2-3002702"
    },
    "Microsoft.AspNetCore.Server.Kestrel": "1.0.0-rc2-final"
  },
  "frameworks": {
    "netcoreapp1.0": {
      "imports": "dnxcore50"
    }
  }
}









	종속된 패키지들을 다시 불러와주십시오.




dotnet restore









	요청을 처리할 로직을 정의하는 Startup.cs 파일을 추가해주십시오.




using System;
using Microsoft.AspNetCore.Builder;
using Microsoft.AspNetCore.Hosting;
using Microsoft.AspNetCore.Http;

namespace aspnetcoreapp
{
    public class Startup
    {
        public void Configure(IApplicationBuilder app)
        {
            app.Run(context =>
            {
                return context.Response.WriteAsync("Hello from ASP.NET Core!");
            });
        }
    }
}









	웹 호스트를 설정하고 시작하는 코드를 Program.cs 파일에 추가해주십시오.




using System;
using Microsoft.AspNetCore.Hosting;

namespace aspnetcoreapp
{
    public class Program
    {
        public static void Main(string[] args)
        {
            var host = new WebHostBuilder()
                .UseKestrel()
                .UseStartup<Startup>()
                .Build();

            host.Run();
        }
    }
}









	앱을 실행해주십시오. (dotnet run 명령을 실행할 때 소스에 변경 사항이 있다면, 앱을 다시 빌드할 것입니다.)




dotnet run









	http://localhost:5000 을 브라우저에서 열어주십시오.




[image: _images/running-output.png]
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Tutorials
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Your First ASP.NET Core Application on a Mac Using Visual Studio Code

By Daniel Roth [https://github.com/danroth27], Steve Smith [http://ardalis.com] and Rick Anderson [https://twitter.com/RickAndMSFT]

This article will show you how to write your first ASP.NET Core application on a Mac.


Sections:


	Setting Up Your Development Environment

	Scaffolding Applications Using Yeoman

	Developing ASP.NET Applications on a Mac With Visual Studio Code

	Running Locally Using Kestrel

	Publishing to Azure

	Additional Resources






Setting Up Your Development Environment

To setup your development machine download and install .NET Core [https://microsoft.com/net/core] and Visual Studio Code [https://code.visualstudio.com] with the C# extension [https://marketplace.visualstudio.com/items?itemName=ms-vscode.csharp].




Scaffolding Applications Using Yeoman

Follow the instruction in Building Projects with Yeoman to create an ASP.NET Core project.




Developing ASP.NET Applications on a Mac With Visual Studio Code


	Start Visual Studio Code



[image: ../_images/vscode-welcome.png]

	Tap File > Open and navigate to your Empty ASP.NET Core app



[image: ../_images/file-open.png]
From a Terminal / bash prompt, run dotnet restore to restore the project’s dependencies. Alternately, you can enter command shift p in Visual Studio Code and then type dot as shown:

[image: ../_images/dotnet-restore1.png]
You can run commands directly from within Visual Studio Code, including dotnet restore and any tools referenced in the project.json file, as well as custom tasks defined in .vscode/tasks.json.

This empty project template simply displays “Hello World!”. Open Startup.cs in Visual Studio Code to see how this is configured:

[image: ../_images/vscode-startupcs.png]
If this is your first time using Visual Studio Code (or just Code for short), note that it provides a very streamlined, fast, clean interface for quickly working with files, while still providing tooling to make writing code extremely productive.

In the left navigation bar, there are four icons, representing four viewlets:


	Explore

	Search

	Git

	Debug



The Explore viewlet allows you to quickly navigate within the folder system, as well as easily see the files you are currently working with. It displays a badge to indicate whether any files have unsaved changes, and new folders and files can easily be created (without having to open a separate dialog window). You can easily Save All from a menu option that appears on mouse over, as well.

The Search viewlet allows you to quickly search within the folder structure, searching filenames as well as contents.

Code will integrate with Git if it is installed on your system. You can easily initialize a new repository, make commits, and push changes from the Git viewlet.

[image: ../_images/vscode-git.png]
The Debug viewlet supports interactive debugging of applications.

Finally, Code’s editor has a ton of great features. You’ll notice unused using statements are underlined and can be removed automatically by using command . when the lightbulb icon appears. Classes and methods also display how many references there are in the project to them. If you’re coming from Visual Studio, Code includes many of the same keyboard shortcuts, such as command k c to comment a block of code, and command k u to uncomment.




Running Locally Using Kestrel

The sample is configured to use Kestrel for the web server. You can see it configured in the project.json file, where it is specified as a dependency.

{
  "version": "1.0.0-*",
  "compilationOptions": {
    "emitEntryPoint": true
  },
  "dependencies": {
    "Microsoft.NETCore.App": {
      "type": "platform",
      "version": "1.0.0-rc2-3002702"
    },
    "Microsoft.AspNetCore.Server.Kestrel": "1.0.0-rc2-final",
    "Microsoft.AspNetCore.Server.Kestrel.Https": "1.0.0-rc2-final",
    "Microsoft.Extensions.Logging.Console": "1.0.0-rc2-final"
  },
  "frameworks": {
    "netcoreapp1.0": {}
  }
}






	Run dotnet run command to launch the app

	Navigate to localhost:5000:



[image: ../_images/hello-world1.png]

	To stop the web server enter Ctrl+C.






Publishing to Azure

Once you’ve developed your application, you can easily use the Git integration built into Visual Studio Code to push updates to production, hosted on Microsoft Azure [http://azure.microsoft.com].


Initialize Git

Initialize Git in the folder you’re working in. Tap on the Git viewlet and click the Initialize Git repository button.

[image: ../_images/vscode-git-commit.png]
Add a commit message and tap enter or tap the checkmark icon to commit the staged files.

[image: ../_images/init-commit.png]
Git is tracking changes, so if you make an update to a file, the Git viewlet will display the files that have changed since your last commit.




Initialize Azure Website

You can deploy to Azure Web Apps directly using Git.


	Create a new Web App [https://tryappservice.azure.com/] in Azure. If you don’t have an Azure account, you can create a free trial [http://azure.microsoft.com/en-us/pricing/free-trial/].

	Configure the Web App in Azure to support continuous deployment using Git [http://azure.microsoft.com/en-us/documentation/articles/web-sites-publish-source-control/].



Record the Git URL for the Web App from the Azure portal:

[image: ../_images/azure-portal.png]

	In a Terminal window, add a remote named azure with the Git URL you noted previously.


	git remote add azure https://ardalis-git@firstaspnetcoremac.scm.azurewebsites.net:443/firstaspnetcoremac.git





	Push to master.


	git push azure master to deploy.



[image: ../_images/git-push-azure-master.png]


	Browse to the newly deployed web app. You should see Hello world!










Additional Resources


	Visual Studio Code [https://code.visualstudio.com]

	Building Projects with Yeoman

	Fundamentals
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Building your first ASP.NET Core MVC Application



	Getting started with ASP.NET Core MVC




	Adding a controller
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	Working with SQL Server LocalDB




	Controller methods and views
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	Adding a New Field




	Adding Validation




	Examining the Details and Delete methods
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Getting started with ASP.NET Core MVC

By Rick Anderson [https://twitter.com/RickAndMSFT]

This tutorial will teach you the basics of building an ASP.NET Core MVC  web app using Visual Studio 2015 [https://www.visualstudio.com/en-us/visual-studio-homepage-vs.aspx].


Install Visual Studio and .NET Core


	Install Visual Studio Community 2015. Select the Community download and the default installation. Skip this step if you have Visual Studio 2015 installed.
	Visual Studio 2015 Home page installer [https://www.visualstudio.com/en-us/visual-studio-homepage-vs.aspx]





	Install .NET Core + Visual Studio tooling [http://go.microsoft.com/fwlink/?LinkID=798306]






Create a web app

From the Visual Studio Start page, tap New Project.

[image: ../../_images/new_project.png]
Alternatively, you can use the menus to create a new project. Tap File > New > Project.

[image: ../../_images/alt_new_project.png]
Complete the New Project dialog:


	In the left pane, tap Web

	In the center pane, tap ASP.NET Core Web Application

	Name the project “MvcMovie” (It’s important to name the project “MvcMovie” so when you copy code, the namespace will match. )

	Tap OK



[image: ../../_images/new_project2.png]
In the New ASP.NET Core Web Application - MvcMovie dialog, tap Web Application, and then tap OK.


경고

You must have the Authentication set to Individual User Accounts in this release for the scaffolding engine to work.



[image: ../../_images/p3.png]
Visual Studio used a default template for the MVC project you just created, so you have a working app right now by entering a project name and selecting a few options. This is a simple “Hello World!” project, and it’s a good place to start,

Tap F5 to run the app in debug mode or Ctl-F5 in non-debug mode.

[image: ../../_images/12.png]

	Visual Studio starts IIS Express [http://www.iis.net/learn/extensions/introduction-to-iis-express/iis-express-overview] and runs your app. Notice that the address bar shows localhost:port# and not something like example.com. That’s because localhost always points to your own local computer, which in this case is running the app you just created. When Visual Studio creates a web project, a random port is used for the web server. In the image above, the port number is 1234. When you run the app, you’ll see a different port number.

	Launching the app with Ctrl+F5 (non-debug mode) allows you to make code changes, save the file, refresh the browser, and see the code changes. Many developers prefer to use non-debug mode to quickly launch the app and view changes.

	You can launch the app in debug or non-debug mode from the Debug menu item:



[image: ../../_images/debug_menu.png]

	You can debug the app by tapping the IIS Express button



[image: ../../_images/iis_express.png]
The default template gives you working Home, Contact, About, Register and Log in links. The browser image above doesn’t show theses links. Depending on the size of your browser, you might need to click the navigation icon to show them.

[image: ../../_images/2.png]
In the next part of this tutorial, we’ll learn about MVC and start writing some code.
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Adding a controller

By Rick Anderson [https://twitter.com/RickAndMSFT]

The Model-View-Controller (MVC) architectural pattern separates an app into three main components: the Model, the View, and the Controller. The MVC pattern helps you create apps that are testable and easier to maintain and update than traditional monolithic apps. MVC-based apps contain:


	Models: Classes that represent the data of the app and that use validation logic to enforce business rules for that data. Typically, model objects retrieve and store model state in a database. In this tutorial, a Movie model retrieves movie data from a database, provides it to the view or updates it. Updated data is written to a SQL Server database.

	Views: Views are the components that display the app’s user interface (UI). Generally, this UI displays the model data.

	Controllers: Classes that handle browser requests, retrieve model data, and then specify view templates that return a response to the browser. In an MVC app, the view only displays information; the controller handles and responds to user input and interaction. For example, the controller handles route data and query-string values, and passes these values to the model. The model might use these values to query the database.



The MVC pattern helps you create apps that separate the different aspects of the app (input logic, business logic, and UI logic), while providing a loose coupling between these elements. The pattern specifies where each kind of logic should be located in the app. The UI logic belongs in the view. Input logic belongs in the controller. Business logic belongs in the model. This separation helps you manage complexity when you build an app, because it enables you to work on one aspect of the implementation at a time without impacting the code of another. For example, you can work on the view code without depending on the business logic code.

We’ll be covering all these concepts in this tutorial series and show you how to use them to build a simple movie app. The following image shows the Models, Views and Controllers folders in the MVC project.

[image: ../../_images/mvc1.png]

	In Solution Explorer, right-click Controllers > Add > New Item



[image: ../../_images/add_controller.png]

	In the Add Scaffold dialog
	Tap MVC Controller - Empty

	Tap Add







[image: ../../_images/new_hell_ctl.png]

	Name the controller HelloWorldController

	Tap Add



[image: ../../_images/hwc.png]
Replace the contents of Controllers/HelloWorldController.cs with the following:

using Microsoft.AspNetCore.Mvc;
using System.Text.Encodings.Web;

namespace MvcMovie.Controllers
{
    public class HelloWorldController : Controller
    {
        // 
        // GET: /HelloWorld/

        public string Index()
        {
            return "This is my default action...";
        }

        // 
        // GET: /HelloWorld/Welcome/ 

        public string Welcome()
        {
            return "This is the Welcome action method...";
        }
    }
}





Every public method in a controller is callable as an HTTP endpoint. In the sample above, both methods return a string.  Note the comments preceding each method:

public class HelloWorldController : Controller
{
    // 
    // GET: /HelloWorld/

    public string Index()
    {
        return "This is my default action...";
    }

    // 
    // GET: /HelloWorld/Welcome/ 

    public string Welcome()
    {
        return "This is the Welcome action method...";
    }
}





The first comment states this is an HTTP GET [http://www.w3schools.com/tags/ref_httpmethods.asp] method that is invoked by appending “/HelloWorld/” to the URL. The second comment specifies an HTTP GET [http://www.w3.org/Protocols/rfc2616/rfc2616-sec9.html] method that is invoked by appending “/HelloWorld/Welcome/” to the URL. Later on in the tutorial we’ll use the scaffolding engine to generate HTTP POST methods.

Run the app in non-debug mode (press Ctrl+F5) and append “HelloWorld” to the path in the address bar. (In the image below, http://localhost:1234/HelloWorld is used, but you’ll have to replace 1234 with the port number of your app.) The Index method returns a string. You told the system to return some HTML, and it did!

[image: ../../_images/hell1.png]
MVC invokes controller classes (and the action methods within them) depending on the incoming URL. The default URL routing logic used by MVC uses a format like this to determine what code to invoke:

/[Controller]/[ActionName]/[Parameters]

You set the format for routing in the Startup.cs file.

app.UseMvc(routes =>
{
    routes.MapRoute(
        name: "default",
        template: "{controller=Home}/{action=Index}/{id?}");
});





When you run the app and don’t supply any URL segments, it defaults to the “Home” controller and the “Index” method specified in the template line highlighted above.

The first URL segment determines the controller class to run. So localhost:xxxx/HelloWorld maps to the HelloWorldController class. The second part of the URL segment determines the action method on the class. So localhost:xxxx/HelloWorld/Index would cause the Index method of the HelloWorldController class to run. Notice that we only had to browse to localhost:xxxx/HelloWorld and the Index method was called by default. This is because Index is the default method that will be called on a controller if a method name is not explicitly specified. The third part of the URL segment ( Parameters) is for route data. We’ll see route data later on in this tutorial.

Browse to http://localhost:xxxx/HelloWorld/Welcome. The Welcome method runs and returns the string “This is the Welcome action method...”. The default MVC routing is /[Controller]/[ActionName]/[Parameters]. For this URL, the controller is HelloWorld and Welcome is the action method. We haven’t used the [Parameters] part of the URL yet.

[image: ../../_images/welcome.png]
Let’s modify the example slightly so that you can pass some parameter information  from the URL to the controller (for example, /HelloWorld/Welcome?name=Scott&numtimes=4).  Change the Welcome method  to include two parameters as shown below. Note that the code uses the C# optional-parameter feature to indicate that the numTimes parameter defaults to 1 if no value is passed for that parameter.

public string Welcome(string name, int numTimes = 1)
{
    return HtmlEncoder.Default.Encode(
        "Hello " + name + ", NumTimes is: " + numTimes);
}






주석

The code above uses HtmlEncoder.Default.Encode to protect the app from malicious input (namely JavaScript).




주석

In Visual Studio 2015, when you are running without debugging (Ctl+F5), you don’t need to build the app after changing the code. Just save the file, refresh your browser and you can see the changes.



Run your app and browse to:


http://localhost:xxxx/HelloWorld/Welcome?name=Rick&numtimes=4


(Replace xxxx with your port number.) You can try different values for name and numtimes in  the URL. The MVC model binding system automatically maps the named parameters from  the query string in the address bar to parameters in your method. See Model Binding for more information.

[image: ../../_images/rick4.png]
In the sample above, the URL segment (Parameters) is not used, the name and numTimes parameters are passed as query strings [http://en.wikipedia.org/wiki/Query_string]. The ? (question mark) in the above URL is a separator, and the query strings follow. The & character separates query strings.

Replace the Welcome method with the following code:

public string Welcome(string name, int ID = 1)
{
    return HtmlEncoder.Default.Encode(
        "Hello " + name + ", ID: " + ID);
}





Run the app and enter the following URL:  http://localhost:xxx/HelloWorld/Welcome/3?name=Rick

[image: ../../_images/rick_routedata.png]
This time the third URL segment  matched the route parameter id. The Welcome  method contains a parameter  id that matched the URL template in the MapRoute method. The trailing ?  (in id?) indicates the id parameter is optional.

app.UseMvc(routes =>
{
    routes.MapRoute(
        name: "default",
        template: "{controller=Home}/{action=Index}/{id?}");
});





In these examples the controller has been doing the “VC” portion  of MVC - that is, the view and controller work. The controller is returning HTML  directly. Generally you don’t want controllers returning HTML directly, since  that becomes very cumbersome to code and maintain. Instead we’ll typically use a separate Razor view template file to help generate the HTML response. We’ll do that in the next tutorial.
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Adding a view

By Rick Anderson [https://twitter.com/RickAndMSFT]

In this section you’re going to modify the HelloWorldController class to use Razor view template files to cleanly encapsulate the process of generating HTML responses to a client.

You’ll create a view template file using the Razor view engine. Razor-based view templates have a .cshtml file extension, and provide an elegant way to create HTML output using C#. Razor minimizes the number of characters and keystrokes required when writing a view template, and enables a fast, fluid coding workflow.

Currently the Index method returns a string with a message that is hard-coded in the controller class. Change the Index method to return a View object, as shown in the following code:

public IActionResult Index()
{
    return View();
}





The Index method above uses a view template to generate an HTML response to the browser. Controller methods (also known as action methods [http://rachelappel.com/asp.net-mvc-actionresults-explained]), such as the Index method above, generally return an IActionResult (or a class derived from ActionResult), not primitive types like string.


	Right click on the Views folder, and then Add > New Folder and name the folder HelloWorld.



[image: ../../_images/add_folder.png]

	Right click on the Views/HelloWorld folder, and then Add > New Item.

	In the Add New Item - MvcMovie dialog
	In the search box in the upper-right, enter view

	Tap MVC View Page

	In the Name box, keep the default Index.cshtml

	Tap Add







[image: ../../_images/add_view.png]
Replace the contents of the Views/HelloWorld/Index.cshtml Razor view file with the following:

@{
    ViewData["Title"] = "Index";
}

<h2>Index</h2>

<p>Hello from our View Template!</p>





Navigate to http://localhost:xxxx/HelloWorld. The Index method in the HelloWorldController didn’t do much work; it simply ran the statement return View();, which specified that the method should use a view template file to render a response to the browser. Because you didn’t explicitly specify the name of the view template file to use, MVC defaulted to using the Index.cshtml view file in the /Views/HelloWorld folder. The image below shows the string “Hello from our View Template!” hard-coded in the view.

[image: ../../_images/hell_template.png]
If your browser window is small (for example on a mobile device), you might need to toggle (tap) the Bootstrap navigation button [http://getbootstrap.com/components/#navbar] in the upper right to see the to the Home, About, Contact, Register and Log in links.

[image: ../../_images/1.png]

Changing views and layout pages

Tap on the menu links (MvcMovie, Home, About). Each page shows the same menu layout. The menu layout is implemented in the Views/Shared/_Layout.cshtml file. Open the Views/Shared/_Layout.cshtml file.

Layout templates allow you to specify the HTML container layout of your site in one place and then apply it across multiple pages in your site. Find the @RenderBody() line. RenderBody is a placeholder where all the view-specific pages you create show up, “wrapped” in the layout page. For example, if you select the About link, the Views/Home/About.cshtml view is rendered inside the RenderBody method.

Change the contents of the title element. Change the anchor text in the layout template to “MVC Movie” and the controller from Home to Movies as highlighted below:
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	<!DOCTYPE html>
<html>
<head>
    <meta charset="utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />
    <title>@ViewData["Title"] - Movie App</title>

    <environment names="Development">
        <link rel="stylesheet" href="~/lib/bootstrap/dist/css/bootstrap.css" />
        <link rel="stylesheet" href="~/css/site.css" />
    </environment>
    <environment names="Staging,Production">
        <link rel="stylesheet" href="https://ajax.aspnetcdn.com/ajax/bootstrap/3.3.6/css/bootstrap.min.css"
              asp-fallback-href="~/lib/bootstrap/dist/css/bootstrap.min.css"
              asp-fallback-test-class="sr-only" asp-fallback-test-property="position" asp-fallback-test-value="absolute" />
        <link rel="stylesheet" href="~/css/site.min.css" asp-append-version="true" />
    </environment>
</head>
<body>
    <div class="navbar navbar-inverse navbar-fixed-top">
        <div class="container">
            <div class="navbar-header">
                <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".navbar-collapse">
                    <span class="sr-only">Toggle navigation</span>
                    <span class="icon-bar"></span>
                    <span class="icon-bar"></span>
                    <span class="icon-bar"></span>
                </button>
                <a asp-controller="Movies" asp-action="Index" class="navbar-brand">Mvc Movie</a>
            </div>
            <div class="navbar-collapse collapse">
                <ul class="nav navbar-nav">
                    <li><a asp-controller="Home" asp-action="Index">Home</a></li>
                    <li><a asp-controller="Home" asp-action="About">About</a></li>
                    <li><a asp-controller="Home" asp-action="Contact">Contact</a></li>
                </ul>
                @await Html.PartialAsync("_LoginPartial")
            </div>
        </div>
    </div>
    <div class="container body-content">
        @RenderBody()
        <hr />
        <footer>
            <p>&copy; 2016 - MvcMovie</p>
        </footer>
    </div>

    <environment names="Development">
        <script src="~/lib/jquery/dist/jquery.js"></script>
        <script src="~/lib/bootstrap/dist/js/bootstrap.js"></script>
        <script src="~/js/site.js" asp-append-version="true"></script>
    </environment>
    <environment names="Staging,Production">
        <script src="https://ajax.aspnetcdn.com/ajax/jquery/jquery-2.2.0.min.js"
                asp-fallback-src="~/lib/jquery/dist/jquery.min.js"
                asp-fallback-test="window.jQuery">
        </script>
        <script src="https://ajax.aspnetcdn.com/ajax/bootstrap/3.3.6/bootstrap.min.js"
                asp-fallback-src="~/lib/bootstrap/dist/js/bootstrap.min.js"
                asp-fallback-test="window.jQuery && window.jQuery.fn && window.jQuery.fn.modal">
        </script>
        <script src="~/js/site.min.js" asp-append-version="true"></script>
    </environment>

    @RenderSection("scripts", required: false)
</body>
</html>








경고

We haven’t implemented the Movies controller yet, so if you click on that link, you’ll get a 404 (Not found) error.



Save your changes and tap the About link. Notice how each page displays the Mvc Movie link. We were able to make the change once in the layout template and have all pages on the site reflect the new link text and new title.

Examine the Views/_ViewStart.cshtml file:

@{
    Layout = "_Layout";
}





The Views/_ViewStart.cshtml file brings in the Views/Shared/_Layout.cshtml file to each view. You can use the Layout property to set a different layout view, or set it to null so no layout file will be used.

Now, let’s change the title of the Index view.

Open Views/HelloWorld/Index.cshtml. There are two places to make a change:



	The text that appears in the title of the browser

	The secondary header (<h2> element).






You’ll make them slightly different so you can see which bit of code changes which part of the app.

@{
    ViewData["Title"] = "Movie List";
}

<h2>My Movie List</h2>

<p>Hello from our View Template!</p>





ViewData["Title"] = "Movie List"; in the code above sets the Title property of the ViewDataDictionary [https://docs.asp.net/projects/api/en/latest/autoapi/Microsoft/AspNet/Mvc/ViewFeatures/ViewDataDictionary/index.html] to “Movie List”. The Title property is used in the <title> HTML element in the layout page:

<title>@ViewData["Title"] - Movie App</title>





Save your change and refresh the page. Notice that the browser title, the primary heading, and the secondary headings have changed. (If you don’t see changes in the browser, you might be viewing cached content. Press Ctrl+F5 in your browser to force the response from the server to be loaded.) The browser title is created with ViewData["Title"] we set in the Index.cshtml view template and the additional “- Movie App” added in the layout file.

Also notice how the content in the Index.cshtml view template was merged with the Views/Shared/_Layout.cshtml view template and a single HTML response was sent to the browser. Layout templates make it really easy to make changes that apply across all of the pages in your application. To learn more see Layout.

[image: ../../_images/hell3.png]
Our little bit of “data” (in this case the “Hello from our View Template!” message) is hard-coded, though. The MVC application has a “V” (view) and you’ve got a “C” (controller), but no “M” (model) yet. Shortly, we’ll walk through how create a database and retrieve model data from it.




Passing Data from the Controller to the View

Before we go to a database and talk about models, though, let’s first talk about passing information from the controller to a view. Controller classes are invoked in response to an incoming URL request. A controller class is where you write the code that handles the incoming browser requests, retrieves data from a database, and ultimately decides what type of response to send back to the browser. View templates can then be used from a controller to generate and format an HTML response to the browser.

Controllers are responsible for providing whatever data or objects are required in order for a view template to render a response to the browser. A best practice: A view template should never perform business logic or interact with a database directly. Instead, a view template should work only with the data that’s provided to it by the controller. Maintaining this “separation of concerns” helps keep your code clean, testable and more maintainable.

Currently, the Welcome method in the HelloWorldController class takes a name and a ID parameter and then outputs the values directly to the browser. Rather than have the controller render this response as a string, let’s change the controller to use a view template instead. The view template will generate a dynamic response, which means that you need to pass appropriate bits of data from the controller to the view in order to generate the response. You can do this by having the controller put the dynamic data (parameters) that the view template needs in a ViewData dictionary that the view template can then access.

Return to the HelloWorldController.cs file and change the Welcome method to add a Message and NumTimes value to the ViewData dictionary. The ViewData dictionary is a dynamic object, which means you can put whatever you want in to it; the ViewData object has no defined properties until you put something inside it. The MVC model binding system [http://docs.asp.net/projects/mvc/en/latest/models/index.html] automatically maps the named parameters (name and numTimes) from the query string in the address bar to parameters in your method. The complete HelloWorldController.cs file looks like this:

using Microsoft.AspNetCore.Mvc;
using System.Text.Encodings.Web;

namespace MvcMovie.Controllers
{
    public class HelloWorldController : Controller
    {
        public IActionResult Index()
        {
            return View();
        }

        public IActionResult Welcome(string name, int numTimes = 1)
        {
            ViewData["Message"] = "Hello " + name;
            ViewData["NumTimes"] = numTimes;

            return View();
        }
    }
}





The ViewData dictionary object contains data that will be passed to the view. Next, you need a Welcome view template.


	Right click on the Views/HelloWorld folder, and then Add > New Item.

	In the Add New Item - MvcMovie dialog
	In the search box in the upper-right, enter view

	Tap MVC View Page

	In the Name box, enter Welcome.cshtml

	Tap Add







You’ll create a loop in the Welcome.cshtml view template that displays “Hello” NumTimes. Replace the contents of Views/HelloWorld/Welcome.cshtml with the following:

@{
    ViewData["Title"] = "About";
}

<h2>Welcome</h2>

<ul>
    @for (int i = 0; i < (int)ViewData["NumTimes"]; i++)
    {
        <li>@ViewData["Message"]</li>
    }
</ul>





Save your changes and browse to the following URL:

http://localhost:xxxx/HelloWorld/Welcome?name=Rick&numtimes=4

Data is taken from the URL and passed to the controller using the model binder [http://docs.asp.net/projects/mvc/en/latest/models/index.html]. The controller packages the data into a ViewData dictionary and passes that object to the view. The view then renders the data as HTML to the browser.

[image: ../../_images/rick1.png]
In the sample above, we used the ViewData dictionary to pass data from the controller to a view. Later in the tutorial, we will use a view model to pass data from a controller to a view. The view model approach to passing data is generally much preferred over the ViewData dictionary approach. See Dynamic V Strongly Typed Views [http://blogs.msdn.com/b/rickandy/archive/2011/01/28/dynamic-v-strongly-typed-views.aspx] for more information.

Well, that was a kind of an “M” for model, but not the database kind. Let’s take what we’ve learned and create a database of movies.
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Adding a model

By Rick Anderson [https://twitter.com/RickAndMSFT]

In this section you’ll add some classes for managing movies in a database. These classes will be the “Model” part of the MVC app.

You’ll use a .NET Framework data-access technology known as the Entity Framework Core [http://ef.readthedocs.org/] to define and work with these data model classes. Entity Framework Core (often referred to as EF Core) features a development paradigm called Code First. You write the code first, and the database tables are created from this code. Code First allows you to create data model objects by writing simple classes. (These are also known as POCO classes, from “plain-old CLR objects.”) The database is created from your classes. If you are required to create the database first, you can still follow this tutorial to learn about MVC and EF app development.


Adding data model classes

In Solution Explorer, right click the Models folder > Add > Class. Name the class Movie and add the following properties:

using System;

namespace MvcMovie.Models
{
    public class Movie
    {
        public int ID { get; set; }
        public string Title { get; set; }
        public DateTime ReleaseDate { get; set; }
        public string Genre { get; set; }
        public decimal Price { get; set; }
    }
}





In addition to the properties you’d expect to model a movie, the ID field is required by the DB for the primary key. Build the project. If you don’t build the app, you’ll get an error in the next section. We’ve finally added a Model to our MVC app.




Scaffolding a controller

In Solution Explorer, right-click the Controllers folder > Add > Controller.

[image: ../../_images/add_controller1.png]
In the Add Scaffold dialog, tap MVC Controller with views, using Entity Framework > Add.

[image: ../../_images/add_scaffold2.png]
Complete the Add Controller dialog


	Model class: Movie(MvcMovie.Models)

	Data context class: ApplicationDbContext(MvcMovie.Models)

	Views:: Keep the default of each option checked

	Controller name: Keep the default MoviesController

	Tap Add



[image: ../../_images/add_controller2.png]
The Visual Studio scaffolding engine creates the following:


	A movies controller (Controllers/MoviesController.cs)

	Create, Delete, Details, Edit and Index Razor view files (Views/Movies)



Visual Studio automatically created the CRUD [https://en.wikipedia.org/wiki/Create,_read,_update_and_delete] (create, read, update, and delete) action methods and views for you (the automatic creation of CRUD action methods and views is known as scaffolding). You’ll soon have a fully functional web application that lets you create, list, edit, and delete movie entries.

Run the app and click on the Mvc Movie link. You’ll get the following error:

[image: ../../_images/pending.png]
That’s a great error message, we’ll follow those instructions to get the database ready for our Movie app.




Use data migrations to create the database


	Open a command prompt in the project directory (MvcMovie/src/MvcMovie). Follow these instructions for a quick way to open a folder in the project directory.


	Open a file in the root of the project (for this example, use Startup.cs.)

	Right click on Startup.cs  > Open Containing Folder.



[image: ../../_images/quick.png]

	Shift + right click a folder > Open command window here



[image: ../../_images/folder.png]

	Run cd .. to move back up to the project directory





	Run the following commands in the command prompt:





dotnet ef migrations add Initial
dotnet ef database update






	dotnet (.NET Core) is a cross-platform implementation of .NET. You can read about it here [http://go.microsoft.com/fwlink/?LinkId=798644].

	dotnet ef migrations add Initial Runs the Entity Framework .NET Core CLI migrations command and creates the initial migration. The parameter “Initial” is arbitrary, but customary for the first (initial) database migration. This operation creates the Data/Migrations/2016<date-time>_Initial.cs file containing the migration commands to add (or drop) the Movie table to the database.

	dotnet ef database update  Updates the database with the migration we just created.






Test the app


	Run the app and tap the Mvc Movie link

	Tap the Create New link and create a movie



[image: ../../_images/movies.png]

주석

You may not be able to enter decimal points or commas in the Price field. To support jQuery validation [http://jqueryvalidation.org/] for non-English locales that use a comma (”,”) for a decimal point, and non US-English date formats, you must take steps to globalize your app. See Additional resources for more information. For now, just enter whole numbers like 10.



Tapping Create causes the form to be posted to the server, where the movie information is saved in a database. You are then redirected to the /Movies URL, where you can see the newly created movie in the listing.

[image: ../../_images/h.png]
Create a couple more movie entries. Try the Edit, Details, and Delete links, which are all functional.




Examining the Generated Code

Open the Controllers/MoviesController.cs file and examine the generated Index method. A portion of the movie controller with the Index method is shown below:

public class MoviesController : Controller
{
    private readonly ApplicationDbContext _context;

    public MoviesController(ApplicationDbContext context)
    {
        _context = context;
    }

    public async Task<IActionResult> Index()
    {
        return View(await _context.Movie.ToListAsync());
    }





The constructor uses Dependency Injection to inject the database context into the controller. The database context is used in each of the CRUD [https://en.wikipedia.org/wiki/Create,_read,_update_and_delete] methods in the controller.

A request to the Movies controller returns all the entries in the Movies table and then passes the data to the Index view.


Strongly typed models and the @model keyword

Earlier in this tutorial, you saw how a controller can pass data or objects to a view template using the ViewData dictionary. The ViewData dictionary is a dynamic object that provides a convenient late-bound way to pass information to a view.

MVC also provides the ability to pass strongly typed objects to a view template. This strongly typed approach enables better compile-time checking of your code and richer IntelliSense [https://msdn.microsoft.com/en-us/library/hcw1s69b.aspx] in Visual Studio (VS). The scaffolding mechanism in VS used this approach (that is, passing a strongly typed model) with the MoviesController class and view templates when it created the methods and views.

Examine the generated Details method in the Controllers/MoviesController.cs file:

// GET: Movies/Details/5
public async Task<IActionResult> Details(int? id)
{
    if (id == null)
    {
        return NotFound();
    }

    var movie = await _context.Movie.SingleOrDefaultAsync(m => m.ID == id);
    if (movie == null)
    {
        return NotFound();
    }

    return View(movie);
}





The id parameter is generally passed as route data, for example http://localhost:1234/movies/details/1 sets:


	The controller to the movies controller (the first URL segment)

	The action to details (the second URL segment)

	The id to 1 (the last URL segment)



You could also pass in the id with a query string as follows:

http://localhost:1234/movies/details?id=1

If a Movie is found, an instance of the Movie model is passed to the Details view:

return View(movie);





Examine the contents of the Views/Movies/Details.cshtml file:

@model MvcMovie.Models.Movie

@{
    ViewData["Title"] = "Details";
}

<h2>Details</h2>

<div>
    <h4>Movie</h4>
    <hr />
    <dl class="dl-horizontal">
        <dt>
            @Html.DisplayNameFor(model => model.Genre)
        </dt>
        <dd>
            @Html.DisplayFor(model => model.Genre)
        </dd>
        <dt>
            @Html.DisplayNameFor(model => model.Price)
        </dt>
        <dd>
            @Html.DisplayFor(model => model.Price)
        </dd>
        <dt>
            @Html.DisplayNameFor(model => model.ReleaseDate)
        </dt>
        <dd>
            @Html.DisplayFor(model => model.ReleaseDate)
        </dd>
        <dt>
            @Html.DisplayNameFor(model => model.Title)
        </dt>
        <dd>
            @Html.DisplayFor(model => model.Title)
        </dd>
    </dl>
</div>
<div>
    <a asp-action="Edit" asp-route-id="@Model.ID">Edit</a> |
    <a asp-action="Index">Back to List</a>
</div>





By including a @model statement at the top of the view template file, you can specify the type of object that the view expects. When you created the movie controller, Visual Studio automatically included the following @model statement at the top of the Details.cshtml file:

@model MvcMovie.Models.Movie





This @model directive allows you to access the movie that the controller passed to the view by using a Model object that’s strongly typed. For example, in the Details.cshtml template, the code passes each movie field to the DisplayNameFor and DisplayFor HTML Helpers with the strongly typed Model object. The Create and Edit methods and view templates also pass a Movie model object.

Examine the Index.cshtml view template and the Index method in the Movies controller. Notice how the code creates a List object when it calls the View method. The code passes this Movies list from the Index action method to the view:

public async Task<IActionResult> Index()
{
    return View(await _context.Movie.ToListAsync());
}





When you created the movies controller, Visual Studio automatically included the following @model statement at the top of the Index.cshtml file:

@model IEnumerable<MvcMovie.Models.Movie>





The @model directive allows you to access the list of movies that the controller passed to the view by using a Model object that’s strongly typed. For example, in the Index.cshtml template, the code loops through the movies with a foreach statement over the strongly typed Model object:

@model IEnumerable<MvcMovie.Models.Movie>

@{
    ViewData["Title"] = "Index";
}

<h2>Index</h2>
<p>
    <a asp-action="Create">Create New</a>
</p>

<table class="table">
    <thead>
        <tr>
            <th>
                @Html.DisplayNameFor(model => model.Genre)
            </th>
            <th>
                @Html.DisplayNameFor(model => model.Price)
            </th>
            <th>
                @Html.DisplayNameFor(model => model.ReleaseDate)
            </th>
            <th>
                @Html.DisplayNameFor(model => model.Title)
            </th>
            <th></th>
        </tr>
    </thead>
    <tbody>
@foreach (var item in Model) {
        <tr>
            <td>
                @Html.DisplayFor(modelItem => item.Genre)
            </td>
            <td>
                @Html.DisplayFor(modelItem => item.Price)
            </td>
            <td>
                @Html.DisplayFor(modelItem => item.ReleaseDate)
            </td>
            <td>
                @Html.DisplayFor(modelItem => item.Title)
            </td>
            <td>
                <a asp-action="Edit" asp-route-id="@item.ID">Edit</a> |
                <a asp-action="Details" asp-route-id="@item.ID">Details</a> |
                <a asp-action="Delete" asp-route-id="@item.ID">Delete</a>
            </td>
        </tr>
}
    </tbody>
</table>





Because the Model object is strongly typed (as an IEnumerable<Movie> object), each item in the loop is typed as Movie. Among other benefits, this means that you get compile-time checking of the code and full IntelliSense [https://msdn.microsoft.com/en-us/library/hcw1s69b.aspx] support in the code editor:

[image: ../../_images/ints.png]
You now have a database and pages to display, edit, update and delete data. In the next tutorial, we’ll work with the database.






Additional resources


	Tag Helpers

	Globalization and localization
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Working with SQL Server LocalDB

By Rick Anderson [https://twitter.com/RickAndMSFT]

The ApplicationDbContext class handles the task of connecting to the database and mapping Movie objects to database records. The database context is registered with the Dependency Injection container in the ConfigureServices method in the Startup.cs file:

// This method gets called by the runtime. Use this method to add services to the container.
public void ConfigureServices(IServiceCollection services)
{
    // Add framework services.
    services.AddDbContext<ApplicationDbContext>(options =>
        options.UseSqlServer(Configuration.GetConnectionString("DefaultConnection")));





The ASP.NET Core Configuration system reads the ConnectionString. For local development, it gets the connection string from the appsettings.json file:

{
  "ConnectionStrings": {
    "DefaultConnection": "Server=(localdb)\\mssqllocaldb;Database=aspnet-MvcMovie-7db2893b-375e-48bd-86a3-bb9779b72ebe;Trusted_Connection=True;MultipleActiveResultSets=true"
  },
  "Logging": {
    "IncludeScopes": false,





When you deploy the app to a test or production server, you can use an environment variable or another approach to set the connection string to a real SQL Server. See Configuration .


SQL Server Express LocalDB

LocalDB is a lightweight version of the SQL Server Express Database Engine that is targeted for program development. LocalDB starts on demand and runs in user mode, so there is no complex configuration. By default, LocalDB database creates “*.mdf” files in the C:/Users/<user> directory.


	From the View menu, open SQL Server Object Explorer (SSOX).



[image: ../../_images/ssox1.png]

	Right click on the Movie table > View Designer



[image: ../../_images/design.png]
[image: ../../_images/dv.png]
Note the key icon next to ID. By default, EF will make a property named ID the primary key.


	Right click on the Movie table > View Data



[image: ../../_images/ssox2.png]
[image: ../../_images/vd22.png]



Seed the database

Create a new class named SeedData in the Models folder. Replace the generated code with the following:

using Microsoft.EntityFrameworkCore;
using Microsoft.Extensions.DependencyInjection;
using MvcMovie.Data;
using System;
using System.Linq;

namespace MvcMovie.Models
{
    public static class SeedData
    {
        public static void Initialize(IServiceProvider serviceProvider)
        {
            using (var context = new ApplicationDbContext(
                serviceProvider.GetRequiredService<DbContextOptions<ApplicationDbContext>>()))
            {
                if (context.Movie.Any())
                {
                    return;   // DB has been seeded
                }

                context.Movie.AddRange(
                     new Movie
                     {
                         Title = "When Harry Met Sally",
                         ReleaseDate = DateTime.Parse("1989-1-11"),
                         Genre = "Romantic Comedy",
                         Price = 7.99M
                     },

                     new Movie
                     {
                         Title = "Ghostbusters ",
                         ReleaseDate = DateTime.Parse("1984-3-13"),
                         Genre = "Comedy",
                         Price = 8.99M
                     },

                     new Movie
                     {
                         Title = "Ghostbusters 2",
                         ReleaseDate = DateTime.Parse("1986-2-23"),
                         Genre = "Comedy",
                         Price = 9.99M
                     },

                   new Movie
                   {
                       Title = "Rio Bravo",
                       ReleaseDate = DateTime.Parse("1959-4-15"),
                       Genre = "Western",
                       Price = 3.99M
                   }
                );
                context.SaveChanges();
            }
        }
    }
}





Notice if there are any movies in the DB, the seed initializer returns.

    if (context.Movie.Any())
    {
        return;   // DB has been seeded
    }





Add the seed initializer to the end of the Configure method in the Startup.cs file:

    app.UseMvc(routes =>
    {
        routes.MapRoute(
            name: "default",
            template: "{controller=Home}/{action=Index}/{id?}");
    });

    SeedData.Initialize(app.ApplicationServices);
}





Test the app


	Delete all the records in the DB. You can do this with the delete links in the browser or from SSOX.

	Force the app to initialize (call the methods in the Startup class) so the seed method runs. To force initialization, IIS Express must be stopped and restarted. You can do this with any of the following approaches:




주석

If the database doesn’t initialize, put a break point on the line if (context.Movie.Any()) and start debugging.



[image: ../../_images/dbg.png]
The app shows the seeded data.

[image: ../../_images/m55.png]







  
  

  
    
      
        Was this page helpful?

        Your feedback about this content is important. Let us know what you think.
        Yes
        No
      

      
        Was this page helpful?

        Sorry this wasn't helpful.
        
        characters remaining
        Submit
        Skip this
      
  
    
    
    Controller methods and views
    
    

    

    
 
  
  

    
      탐색

      
        	
          색인

        	
          다음 |

     